English |
  • 美国VPS主机推荐
  • |
  • 代购服务
  • |
  • 10美元以下VPS
  • |
  • VPS新手指南/教程
  • |
  • 留言板
  • |
  • 关于
  • | 登录 |

    nginx: [warn] the "log_format" directive may be used only on "http" level 解决方法

    2012年02月18日 上午 | 作者:

    一直不提倡使用最新的版本,不过也真因为有部分爱折腾的才会不断的发现问题。目前Nginx的稳定版本是1.0.12,Nginx升级到1.1.1*版本后,会出现nginx: [warn] the "log_format" directive may be used only on "http" level in /usr/local/nginx/conf/nginx.conf:84的警告。

    将/usr/local/nginx/conf/nginx.conf 里server段里的下面代码移出放到该server段的前面即可。
    查看全文 »